Get in touch
Back
Resolved

CDNs have been fixed after AWS Outage!

Started 20 Oct at 02:38am EDT.

AODevs CDN AOUA CDN Images CDN WatchedMovieZ CDN
Created

The AWS outage caused many websites, systems, and apps to stop working.

Posted 20 Oct at 02:38am EDT.